[Resolved] cURL error 28: Connection timed out after 10000 milliseconds

Home Forums Support [Resolved] cURL error 28: Connection timed out after 10000 milliseconds

Home Forums Support cURL error 28: Connection timed out after 10000 milliseconds

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #1488868
    Marc

    Hi there,

    I’m having some problems getting the GP Premium plugin to work with my license key on http://www.odspchronicles.com. I know this isn’t unique, but when trying to activate it, I get the dreaded cURL error 28: Connection timed out
    after 10000 milliseconds message. I decided to contact my Dreamhost support after coming across this support page at https://docs.generatepress.com/article/curl-error-28-connection-timed-out/ — doing the pre-topic check, I saw something about an OBH firewall issue but I have no clue what that is since I’m a bit technologically dense. πŸ˜‰

    So I’m still posting this here since I’m not sure what is causing my error specifically. the following is the e-mail I sent explaining the problem and Dreamhost’s response:

    “Hi there,

    I use the Generate Press theme on my website and I’m trying to
    activate the license key for the premium version. While I can
    download the .zip file from their website and install it through the
    plugins section, the license key is what enables it to receive
    automatic updates through the WordPress dashboard.

    Every time I try activating the license key however, it doesn’t work.
    I also get the following message: cURL error 28: Connection timed out
    after 10001 milliseconds

    Looking through their support documentation, it appears that Generate
    Press needs to communicate with my site to activate the license key.
    This error seems to indicate something is preventing that from
    happening. Here’s their page on it specifically:
    https://docs.generatepress.com/article/curl-error-28-connection-timed-out/

    Since I’m not technically minded whatsoever, I don’t know what to do
    on my end to figure this out or if it’s a server issue. I do know
    that the premium plugin is activated on my http://www.blindluminations.com
    domain and seems to work on all sub-domains there.

    Any help with this would be greatly appreciated. Thanks in advance!”

    This was their response:

    “Hello,

    Thanks for writing in, and sorry about the delay in replying.

    We do not have anything on our end setting with a 10 second timeout.

    It could be that their IP has been blocked. If we had an IP to check we
    might be able to confirm.

    Please let us know if you’re able to provide an IP for us to check or if
    there is anything you’d like us to check on your web server.”

    Like I mentioned before, I’m kind of an idiot when it comes to this stuff so, based on this information, can someone help me out? Thought there might be a way to look at where the problem is coming from or which IP I should try whitelisting with Wordfence as well. (Although I did try activating the key with both WPBruiser and Wordfence deactivated to no avail.) Thanks in advance!

    #1489239
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    We’ve seen this issue with Dreamhost before, unfortunately.
    https://generatepress.com/forums/topic/yet-another-curl-error-28-connection-timed-out-after-10001-milliseconds/page/2/#post-1477629

    It’s likely that their firewall is preventing the communication with our server, as we’ve checked multiple IPs from our users who are hosted with them and none of them have been banned on our end.

    If you tell them our domain (generatepress.com), they’ll be able to get the IP address to check to see if it’s blocked.

    #1499014
    Marc

    Hi Tom, I contacted Dreamhost customer support with the info you gave me in your last message and this was their response:

    “Hi Marc,

    I looked for their IP but I have no way of knowing what IP address the
    server is actually trying to communicate with, but I didn’t find a block
    for 35.193.232.176

    I did notice that the http and https settings were split. Normally the
    https service copies the http settings, however, http was set to add the
    www, while https was set to remove the www and using two different users.
    They are now running add www for http and https under the same user.

    Can you test the connection to generatepress.com again please? (Make sure
    to clear your browser cache, history, as well as the wp-super-cache as
    well)”

    I cleared my cache from WP Supercache and browser history before trying to activate my key again but still received the same error. After doing so, I contact Dreamhost tech support again and this is what they said:

    “Looking into this, we cannot reach the destination, which is why the
    connection is failing. Please see below:

    fossil => 35.193.232.176
    Start: 2020-10-21T10:39:34-0700
    HOST: Loss% Snt Last Avg Best Wrst
    StDev
    1.|– 69.163.224.1 0.0% 10 0.9 1.1 0.8 2.3
    0.5
    2.|– 66.33.200.2 0.0% 10 0.4 0.3 0.2 0.5
    0.1
    3.|– 66.33.200.0 0.0% 10 0.4 0.4 0.3 1.4
    0.3
    4.|– 198.32.195.34 0.0% 10 4.2 5.6 4.1 13.0
    2.7
    5.|– 74.125.243.194 0.0% 10 5.5 5.2 4.6 5.7
    0.4
    6.|– 142.250.228.152 10.0% 10 12.3 347.6 11.6 3029.
    1005.8
    7.|– 74.125.37.82 10.0% 10 35.7 38.2 34.7 49.0
    5.1
    8.|– 209.85.251.154 0.0% 10 1050. 548.9 44.6 3068.
    978.9
    9.|– 142.250.235.40 0.0% 10 45.3 48.6 43.6 81.8
    11.7
    10.|– 216.239.58.74 10.0% 10 44.5 45.2 43.3 47.3
    1.3
    11.|– 216.239.58.169 20.0% 10 46.7 46.8 45.0 48.7
    1.2
    12.|– ??? 100.0 10 0.0 0.0 0.0 0.0
    0.0

    After hop 11, we lose the connection. I checked other servers and I am
    able to reach the destination. Is there anyway that
    https://generatepress.com can ensure 69.163.224.114 is not blocked? In
    the meantime, we can try moving you to another server, however DNS will
    change. If you are using outside DNS, you will have up to 5 days to
    update your DNS to the new IP.”

    Any further assistance you can offer would be greatly appreciated again. Thanks in advance!

    #1500459
    Tom
    Lead Developer
    Lead Developer

    Thanks for this – very helpful!

    Can you give it a shot now?

    #1500603
    Marc

    Awesome, works perfectly now! Thanks for putting up with my website ignorance, I’m very grateful for the assistance! πŸ™‚

    #1501718
    Tom
    Lead Developer
    Lead Developer

    Awesome, glad it worked! πŸ™‚

    #1637775
    Terry Chadban

    Hi guys, looks like this is a common problem, I have the same problem with Fast Comet hosting. They have confirmed that if they turn off their firewall, the update activation code works, but as soon as they enable the firewall again the cURL error returns. So they have asked that I get the IP address of your server so that they can whitelist it in their firewall rules.

    Given the number of people looking for a solution, it might be worthwhile posting the IP address in a FAQ?

    Cheers,
    Terry Chadban

    #1638549
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Here you go: 35.193.232.176

    Hope it works! πŸ™‚

    #1638932
    Terry Chadban

    Hi Tom,
    Thanks for that, the support team have whitelisted the IP address and the update option is working fine now. I even signed up for the beta versions on that website — it is just a live demo website for clients to preview their new website so it won’t be the end of the world if it breaks occasionally.

    But the question still remains — why is the plugin triggering a firewall block on so many different and varied web hosting services? We use dozens of premium plugins and half a dozen premium themes and I have never had a problem with any of them ‘phoning home’ before? I have asked the support team to check their logs to see why it was blocked, but I think that your developers need to re-examine why it is happening too. It is not good enough for a premium plugin developer to say “it is only happening in a few cases, so it isn’t a high priority with us”. It is happening on some of the biggest WordPress web hosts out there so it is a problem.

    Cheers,
    Terry Chadban

    #1639776
    Tom
    Lead Developer
    Lead Developer

    It is a problem, I agree. However, the problem is communication between servers – not the code that’s actually checking and performing the updates. The updater we use (Easy Digital Downloads Software Licensing) is used in most of the premium plugins that you purchase – the “phone home” functionality is all the same.

    The issue comes down to two servers communicating with each other via cURL. There are tons of security measures in place with our server (and hopefully yours) that try to prevent malicious activity like DDoS attacks.

    While it seems like a very common issue here – it’s a very small percentage of users that are actually running into it. The majority of our customers activate their license keys and receive updates with no issue at all. The users that run into these server issues post in the forum (not the ones that have no issues), so it seems like a much bigger problem than it actually is.

    While it’s an issue I’d like to eliminate completely, I’m not able to tell my server to let its guard down completely.

    Glad that allowing the IP worked on your end πŸ™‚

    #1798126
    Aditya Bhosale

    Hello Tom,
    My website is hosted on Dreamhost too and I’ve been facing the same issue since last 3 days. I’ve contacted my hosting provider several times and as per them nothing is stopping the plugin to activate from their side.

    This is what their response was:
    Tell them that your IP has been cleared of any blocks our firewall application system that could be blocking the use of the license. We also verified any band in your IP and there are none whatsoever. We also checked your WordPress installation and it’s working perfect, and that for the tie you reached to us, after we tried to input 3 or 4 times the license, there is no record of an error in our system.

    Any help with this would be greatly appreciated. Thanks in advance!”

    #1798171
    Elvin
    Staff
    Customer Support

    Hi Aditya,

    Any chance you can open a new topic for this?

    So you can use the private information text field to provide the site details. So we can check if the same error is still occurring.

    Let us know. Thank you.

    A wise man once said:
    "Have you cleared your cache?"

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.