[Resolved] "Cooked" plugin not working properly when using search & sorting features

Home Forums Support "Cooked" plugin not working properly when using search & sorting features

  • This topic has 19 replies, 3 voices, and was last updated 1 year ago by Tom.
Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #956507
    Benjamin

    Hey there,

    I have a problem regarding the search and sorting features of the “Cooked” plugin on my website since I’m using the GeneratePress theme.

    When I want to search something or try to sort the list of recipes in a different way it doesn’t show the expected results. I just land on the same page where nothing changed. There’s just some design issues that appear (for example on the top left).

    You can see that if you try to search something or if you change the sorting in the main section here: https://kontaktgrillrezepte.de/tefal-optigrill-fleisch-grillen/

    So there’s clearly something not working properly… Before switching to GeneratePress I used the “Bandana” theme and everything worked fine.

    Any idea what’s wrong? I already tried deactivating some Plugins (like Autoptimize) but nothing helped. The plugin creator also told me that is has something to do with the theme…

    Thanks in advance!

    Regards,
    Benjamin

    #956773
    David
    Staff
    Customer Support

    Hi there,

    i can’t see what the theme would do that would effect the plugin.
    What happens if you temporarily switch to the TwentySeventeen theme?

    #956914
    Benjamin

    Hey David,

    when I switch to a different template everything works fine… that’s why I assume it must have something to do with GeneratePress.

    What I noticed was that when I used the pagination of the Cooked plugin (I recently deactivated it because it also failed to work properly) with the GeneratePress theme it generated a different slug for the second or third page than before, when I was using the Bandana theme.

    Slug for 2nd page with Bandana theme: “/page/2/?paged=2” (showed page 2, everything fine)
    Slug for 2nd page with GeneratePress theme: “/?paged=2” (showed page 1 instead, with some design issues)

    Does this help?

    #957199
    Tom
    Lead Developer
    Lead Developer

    GeneratePress doesn’t have any say over permalinks, so it’s strange that they’re different. The format changes like this if you switch between themes on the same site?

    Are you using a child theme with any functions?

    #957310
    Benjamin

    That seems strange…but when I use a different theme it uses different permalinks.
    I don’t have any child themes installed. I’m just using the GeneratePress Pro with all Premium modules activated.

    #957612
    Tom
    Lead Developer
    Lead Developer

    Do you have any code added inside Elements or GP Hooks which could be affecting the permalinks?

    #957789
    Benjamin

    No, I didn’t change anything there…

    What I just found out: When I add a comment on one of the pages (normal WP comments), the comment is published but I instantly land the homepage (URL is “https://kontaktgrillrezepte.de/wp-comments-post.php”) and there I get the same design errors like when I use the sorting or search features with the Cooked plugin…

    Does it mean that there might be a general PHP problem with the whole theme…?

    #957875
    Tom
    Lead Developer
    Lead Developer

    If it was a problem with the theme, the issue would be present on all websites using it (including the one we’re on now).

    Does the comment issue happen with the Cooked plugin turned off?

    It sounds like the redirects in WordPress are broken. What do you have set as your permalinks in “Settings > Permalinks”?

    #958451
    Benjamin

    I just deactivated the Cooked plugin but the comment issue still happened…

    I use this custom permalink structure: “https://kontaktgrillrezepte.de/%category%/%postname%/”

    #958539
    Tom
    Lead Developer
    Lead Developer

    What if you choose “Post Name”? Does the issue go away?

    The fact that comments are broken without the plugin tells me something about your permalinks/redirects are broken.

    #961312
    Benjamin

    I changed the permalinks to Post Name but that didn’t resolve the issue…

    #961550
    Tom
    Lead Developer
    Lead Developer

    And just to confirm, if you switch this exact site to one of the default Twenty-something themes, the issue goes away?

    Have you made any changes to your .htaccess file?

    #964339
    Benjamin

    Yes it did work when I switched to a different template.

    This is the content of my .htaccess:

    php_value upload_max_filesize 2500M
    php_value post_max_size 2500M
    php_value memory_limit 256M

    # BEGIN rlrssslReallySimpleSSL rsssl_version[3.2]
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTPS} !=on [NC]
    RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]
    </IfModule>
    # END rlrssslReallySimpleSSL
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    ## BEGIN GZIP Compression ##
    <IfModule mod_deflate.c>
    AddOutputFilterByType DEFLATE text/plain
    AddOutputFilterByType DEFLATE text/html
    AddOutputFilterByType DEFLATE text/xml
    AddOutputFilterByType DEFLATE text/css
    AddOutputFilterByType DEFLATE application/xml
    AddOutputFilterByType DEFLATE application/xhtml+xml
    AddOutputFilterByType DEFLATE application/rss+xml
    AddOutputFilterByType DEFLATE application/javascript
    AddOutputFilterByType DEFLATE application/x-javascript
    AddOutputFilterByType DEFLATE application/x-httpd-php
    AddOutputFilterByType DEFLATE application/x-httpd-fastphp
    AddOutputFilterByType DEFLATE image/svg+xml
    SetOutputFilter DEFLATE
    </IfModule>
    ## END GZIP Compression ##

    # TN – START EXPIRES CACHING #
    <IfModule mod_expires.c>
    FileETag MTime Size
    AddOutputFilterByType DEFLATE text/plain text/html text/xml text/css application/xml application/xhtml+xml application/rss+xml application/javascript application/x-javascript
    ExpiresActive On
    ExpiresByType text/html “access 600 seconds”
    ExpiresByType application/xhtml+xml “access 600 seconds”
    ExpiresByType text/css “access 1 month”
    ExpiresByType text/javascript “access 1 month”
    ExpiresByType text/x-javascript “access 1 month”
    ExpiresByType application/javascript “access 1 month”
    ExpiresByType application/x-javascript “access 1 month”
    ExpiresByType application/x-shockwave-flash “access 1 month”
    ExpiresByType application/pdf “access 1 month”
    ExpiresByType image/x-icon “access 1 year”
    ExpiresByType image/jpg “access 1 year”
    ExpiresByType image/jpeg “access 1 year”
    ExpiresByType image/png “access 1 year”
    ExpiresByType image/gif “access 1 year”
    ExpiresByType image/svg+xml “access 1 year”
    ExpiresDefault “access 1 month”
    </IfModule>
    # TN – END EXPIRES CACHING #

    #964596
    Tom
    Lead Developer
    Lead Developer

    Super strange, any chance you can send me temporary admin login details so I can take a closer look?: https://generatepress.com/contact

    Let me know 🙂

    #964700
    Benjamin

    Just sent you an e-mail 🙂

Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.