[Resolved] Conflict between GP-Premium and Elementor's Post Navigation widget

Home Forums Support [Resolved] Conflict between GP-Premium and Elementor's Post Navigation widget

Home Forums Support Conflict between GP-Premium and Elementor's Post Navigation widget

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #669222
    kerawelt

    Hello Support team,

    When creating a “Single” (Post) template in Elementor 2.2 I encountered the following problem.

    When I tried to insert the Post Navigation widget at the bottom of the post, neither “Previous” nor “Next” mentions appeared.

    When I disable GP-Premium, the Post Navigation widget does display.

    Any clue about what might be the cause of the problem ?

    In GP-Premium I had disabled the Top Bar and the Header for my Home page.

    I still can fiddle with the Margin of the Advanced tab in Elementor to achieve that.
    But in the meantime, is there a way to disable the Top Bar and the Header of that particular page through CSS ?

    Many thanks in advance.

    Schlomoh

    GeneratePress 2.1.4
    GP Premium 1.7.2
    #669257
    David
    Staff
    Customer Support

    Hi there,

    1. you can try unchecking post navigation in Customiser > Layout > Blog > Single > Post Navigation.

    2. Layout Elements:
    https://docs.generatepress.com/article/layout-element-overview/

    #669467
    kerawelt

    Many thanks David !
    But Customiser > Layout > Blog > Single > Post Navigation *is already unchecked* in my settings.

    Also I’m sorry but I do not understand the reference to the Layout Elements video…
    I was just asking if there was some CSS code that could disable the Top bar and the Header for a particular page.

    Many thanks for your support.

    #669474
    David
    Staff
    Customer Support

    The code Tom provides here and the topic will provide the fix for the nav.

    https://generatepress.com/forums/topic/disabling-theme-post-navigation-without-disabling-elementors-post-navigation/#post-449591

    With the Layout Element you can disable the Top Bar and then set the Display Rules and select the pages / posts that you don’t want it displayed.

    #669616
    kerawelt

    Many Many thanks David !
    It works !
    Tom is a real crackerjack !
    You are a tremendous support team !
    Schlomoh

    #669673
    David
    Staff
    Customer Support

    You’re welcome , glad we could be of help.

    #761300
    Ashish

    Many thanks, David! I faced the same problem and this worked —> 1. you can try unchecking post navigation in Customiser > Layout > Blog > Single > Post Navigation.
    πŸ˜‰ πŸ™‚ Great work & support, team GP!

    #761349
    David
    Staff
    Customer Support

    Glad to hear you found it useful πŸ™‚

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.