[Resolved] Change landing page

Home Forums Support [Resolved] Change landing page

Home Forums Support Change landing page

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #781786
    Annalena

    Hi!

    I still have trouble with slow loading site so I was going to change my landing page to one with less images, but when I change that, and click on my shop button, I get back to the landing page. Can you please tell me why the link to my shop changes (and my shop disappear) when switching the landing page from it to another page?

    Hope you understand what I mean;)

    I don’t know what to do to speed up my site, I have the Smush plugin and the autoptimize, and some others to help my site load faster. Any other suggestions?

    Thanks for super support!

    #782006
    David
    Staff
    Customer Support

    Hi there,

    i am not seeing any bad re-directions. But your sites main URL does take me to the Shop and not to the Welcome page. If this is not the case for you, have you tried clearing you browser cache?

    If this not the problem, then let me know.

    #782406
    Annalena

    Hi David!

    My landing page for the moment is the shop, but I’d like to change it to my welcome page, (välkommen in swedish), but when I do, and klick the shop button, I won’t get to the shop, why might that be?

    Thanks!

    #782416
    David
    Staff
    Customer Support

    In your page list is there an actual Shop page? If so then try rebuilding your menu after changing the home page and make sure the Shop Menu item points to the shop page. Let me know

    #782641
    Annalena

    Hello again!

    Thanks David! I managed to get it right, but then I have this text “home/product” on the shop page and that doesn’t look good. Can I remove that?

    Thanks again!

    #782646
    Annalena

    But anyhow, my site is still loading to slow. I’m getting “Add Expires headers”, “Use cookie-free domains” and “Make fewer HTTP requests” from Pingdom. Is that something I can fix myself without any coding experience?

    Kindest regard!

    #782670
    David
    Staff
    Customer Support

    So add this CSS:

    .woocommerce.post-type-archive .woocommerce-breadcrumb {
        display: none;
    }

    you have autoptimize installed, can you go to it settings and check that they match our recommendations:

    https://generatepress.com/fastest-wordpress-theme/

    #782680
    Annalena

    The CSS fixed the breadcrumb text:)
    Yes! I have followed your recommendations in the settings.

    #782715
    David
    Staff
    Customer Support

    so the biggest delay is to do with your host, i am seeing waiting times of 2.3 seconds when tested on a european server – once the wait is over it is only taking a second to load. Aside of clearing your Autoptimize cache to remove any residual requests, theirs not much more to do. I would speak with your host about the delay.

    #783847
    Annalena

    Thanks David!

    I’ll contact them to see what they can do.

    Best regards

    #783871
    David
    Staff
    Customer Support

    You’re welcome 🙂

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.