[Resolved] Catalyst theme: Blog page: no excerpts, no title

Home Forums Support Catalyst theme: Blog page: no excerpts, no title

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1403951
    mkjj

    I have quite some issues getting the blog page to work. I set the blog page to show the excerpt, but it shows the full text and NO titles at all. The single post seems to be fine.

    What am I missing here? Any ideas?

    #1404144
    Leo
    Staff
    Customer Support

    Hi there,

    Any chance you can link us to the site in question?

    I don’t see the issue in the original Catalyst template:
    https://gpsites.co/catalyst/blog/

    You can edit the original topic and use the private URL field.

    Let me know 🙂

    #1404366
    mkjj

    Added the URL to the original post. (The site is still under construction.) I don’t see these issues in the original template neither. It’s very likely my fault, but the settings seem to be ok.

    #1404511
    David
    Staff
    Customer Support

    Hi there,

    edit the Post and change the Format to Standard ( default )

    #1404609
    mkjj

    I’ve just checked all posts. They are set to Standard. I created a new post for test purposes. No luck, the blog page shows no title and the full text instead of the excerpt.

    I temporarily deactivated the functions.php in my child theme. Made no difference. If I change the content.php (line 67) from the_content() to the_excerpt() the blog page changes and shows the excerpt. If I add

    <?php the_title( '<h3>', '</h3>' ); ?>

    right before the the content on line 66, the title is shown on the blog page. If I add it to the header section (line 45) it is NOT shown on the blog page.

    #1404731
    mkjj

    To exlude any conflicts I’ve just deactivated all other plugins and activated the Generatepress parent theme. The issues remain. I’ve checked it on my staging server. Everything works perfectly fine. I really have no clue what’s going on here. Both sites run on the same server. I rechecked the PHP configuration. Both are on PHP 7.3.

    The original site was made by an amateur who used a pagebuilder heavily. But that should not cause these issues, I guess. Anyway, I removed the crap and cleaned all posts. So, everything should be ok. Obviously, I am missing something.

    #1404875
    David
    Staff
    Customer Support

    Can you check the Post Format you have set – as every post on your Blog is set to Aside. It has to be set to Standard

    #1404885
    mkjj

    You are awesome, guys. I thought by “Standard” you meant the layout settings. I haven’t even thought about the post type! That did the trick. Thanks a bunch.

    #1404947
    David
    Staff
    Customer Support

    Glad to be of help 🙂

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.