[Support request] Can't upload my images

Home Forums Support [Support request] Can't upload my images

Home Forums Support Can't upload my images

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #786515

    Disclaimer; I’m a complete beginner when it comes to building a website


    I bought 2 professional logos to place on my blog. When I go to customize > Side identity > logo > Upload file, I can’t ” select ” my files.

    It says;

    Maximum upload file size: 128 MB.

    Suggested image dimensions: 350 by 70 pixels.

    So surely this is my files not fitting these requirements but how do I go making them fit these requirements ? The guy that made the logos sent me the Vector and source files as well.

    I just purchased illustrator but for something that seem so simple, couldnt it be done with such an editing on the file somewhere? I can’t seem to find anything yet. I’m stuck with it for days noq lol.

    Customer Support

    Hi there,

    Have you solved this?

    I can see a logo uploaded in the header:


    Hello leo, thank you for your reply
    No, this logo was one I tried the first time to see how it works. I took it from google images.
    I bought other logos but I can’t upload these files, my thought is that the dimensions/size doesnt fit the requirements above. But if that’s the real cause, I don’t know how to fix the size/dimension and would like some guiding here

    Customer Support

    There isn’t any dimension limit. The 350 by 70 pixels is just a suggestion.

    Is your logo exceeding 128MB? That’s pretty big for a logo image.


    I see
    So what could be the reason I can’t upload the files?

    I can upload every png I got on my computer that are next to these files as well
    The logos are PNGs and here is the size of one; 322 537 octets so about 0,30MB…

    Customer Support

    Try #1 here to eliminate any plugin conflicts first

    If not then contact your host and see if they see anything wrong.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.