[Resolved] Can't update a certain page

Home Forums Support [Resolved] Can't update a certain page

Home Forums Support Can't update a certain page

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #619517
    Louie

    I am trying to remove a graphic from a page on my site.
    When I do, and click Update, I get the following error message:
    Request Entity Too Large
    The requested resource
    /wp-admin/post.php
    does not allow request data with POST requests, or the amount of data provided in the request exceeds the capacity limit.

    Does anyone know why this would be after removing something? Never had this problem pop up before.
    Thanks.

    GeneratePress 2.1.3
    GP Premium 1.6.2
    #619673
    David
    Staff
    Customer Support

    Hmmm…. if it didn’t fail when uploading then i can’t see it is a memory limit issue, although that maybe worth checking. The alternative could be corrupted cookie files. So try clearing you cache and cookie data for the site.

    #620470
    Louie

    After doing some research and calling Godaddy. I came across the article below.
    Can you please tell me where Generatepress’ theme’s functions.php file is located?

    Fixing 413 Request Entity Too Large Error in WordPress
    There are multiple ways to fix the request entity too large error in WordPress. We will cover all these methods, and you can try the one that works best for you.

    Method 1. Increase Upload File Size Limit via Functions File

    Simply add the following code to your theme’s functions.php file or a site-specific plugin.

    1
    2
    3
    @ini_set( ‘upload_max_size’ , ’64M’ );
    @ini_set( ‘post_max_size’, ’64M’);
    @ini_set( ‘max_execution_time’, ‘300’ );
    You can increase the values in upload_max_size and post_max_size to be more than the file you are trying to upload. You will also need to increase the max_execution_time to the time you think it would take for the file to upload. If you are unsure, then you can try doubling this value.

    #620667
    David
    Staff
    Customer Support

    Hi there,

    the theme function file is not really the place to add these variables.
    Depending on which hosting plan and the server they provide will vary on where these settings should be applied.

    This article here shows the variations, although doesn’t give much other detail.

    https://uk.godaddy.com/help/php-upload-limits-on-shared-hosting-1475

    Generally these settings would be applied in the server cPanel or Plesk if it has that. or within the php.ini, user.ini or htaccess file all of which are in the root directory of your site, depending on the type of installation.

    Can you go back and clarify this with them?

    #620673
    Louie

    thanks – I will call them again tomorrow.

    #620675
    David
    Staff
    Customer Support
    #620986
    Louie

    Turns out, after looking at the source on the page, there were about 2,000 <p> </p> in a row. That is what must have eaten up the upload size. Took it out and no problem uploading! Thank you for your help.

    #621003
    David
    Staff
    Customer Support

    Wow, thats a lot of p tags. Glad to hear you got it resolved.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.