[Support request] Can't edit the page which I establish as "posts page" with plugin Elementor

Home Forums Support Can't edit the page which I establish as "posts page" with plugin Elementor

  • This topic has 3 replies, 2 voices, and was last updated 9 months ago by David.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1107697
    Carlos Antonio

    Hello everyone,

    The problem is that when I establish a page (blog) as “posts page” and I try to edit it with Elementor, it appears the following message:

    “Sorry, the content area was not found in your page. You must call the_content function in the current template, in order for Elementor to work on this page.

    Looking for a solution, I found Elementor support says:

    Have you or the theme‚Äôs developer created a custom WordPress page template for your theme that does not include the_content function? You will need to include the_content in your code to edit it with Elementor, or switch to a different theme, which often solves the problem. First, try switching to a theme like Twenty Seventeen or GeneratePress and see if your problem is solved. If you are a web developer and are developing a theme, add the_content function into the page template’s code. This is the line you need to add: <?php the_content(); ?> If you are not familiar with where to place this code or how to add it to the page, please contact your website developer so it can be implemented properly as we cannot provide full support for that. Please note that adding this code won’t enable the editing of Archive pages and Latest Post pages (these pages have to be edited via the theme builder of Elementor) and it is really simple.

    As the rest of the pages work perfectly with Elementor, I understand that the “content function” is already included in the theme.

    What can I do?

    Thanks in advance

    #1107857
    David
    Staff
    Customer Support

    Hi there,

    you cannot edit the Blog or Archive pages, as they are not pages but created by a function.
    To build them using Elementor you must have Elementor Pro where you can create Theme Templates.

    #1107901
    Carlos Antonio

    Finally solved the problem.

    The thing was that I was creating my blog page with the Pro function “posts” widget, but, in “Reading Settings” I was still marking in “posts page” the page that I called blog. That was activating the default configurated blog page instead of the page that I wanted.

    The solution is to leave EMPTY the “posts page” box by marking the option “-select-” and saving changes.

    Thanks for the support and have a nice day.

    #1109594
    David
    Staff
    Customer Support

    Glad to hear you got it resolved

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.