[Support request] Blog archive page loads very slowly

Home Forums Support [Support request] Blog archive page loads very slowly

Home Forums Support Blog archive page loads very slowly

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #591186
    Leon

    Hello,

    My blog archive page loads very slowly (about 15s). And the featured image size set on customizer doesn’t apply on the archive page either. I didn’t add anything extra to the page but some built in sidebar widgets.

    Other pages and posts all load well.

    Could you help take a look into the archive page please? This is the blog page: https://interpreterdatabase.com/interpreter-community

    (Sometimes you may find it loads fast because cache is enabled. But in most cases, even if cache is enabled, the speed is still slow and if you are logged in, cache disabled, it will load slowly)

    I think I asked for this support before. But I wasn’t able to fix the problem by then. And after some updates of theme and plugins, the problem is still there.

    Thank you
    Leon

    GeneratePress 2.1.2
    GP Premium 1.6.2
    #591619
    Leo
    Staff
    Customer Support

    Hi there,

    Ran the site through GTMetrix and the result is very good:
    http://www.screencast.com/t/dugqNnpKhb

    It also loads super fast for me as well.

    Have you fixed this?

    #598329
    Leon

    No Leo. I haven’t fixed this yet. And it’s giving me headache…

    I installed query monitor, which shows that TTFB of the page is 12s, which is way to slow and I cant tell the reason.

    At the same time, other pages load normally. This is wierd.

    Leon

    #598364
    Tom
    Lead Developer
    Lead Developer

    I just ran it through Pingdom and found this: https://www.screencast.com/t/38lWCg3mQ

    Does that script name ring any bells? I think it may be the issue.

    #598402
    Leon

    Hi Tom,

    Thanks for checking.

    Im pretty sure the script from Baidu is not the cause. Because the problem happened before i added the script.

    The script is just like the google analytics script.

    Ill try swiching to default theme and see if it gets fixed.

    Thank you.

    #598686
    Tom
    Lead Developer
    Lead Developer

    In that test the Baidu script took 3 seconds to load. The script itself can be very small, but if the server it’s hosted on is slow sometimes, it will slow down your page load.

    Did you find anything out by switching to the default theme?

    #598760
    Leon

    Hi Tom,

    Baidu is the largest search engine in China and they have cdn enabled worldwide. It may load slower in North America and Europe, but pretty fast in Asia. Of course, your point is well understood. But I’m pretty sure that’s not what caused the blog page to load slowly as I added that code a few days ago, but slow loading blog page happened almost a few months ago.

    Good news is: by switching to 2017 theme, the blog pages loads just as well as other pages, meaning the problem is solved.

    Looks like it has something to do with the theme. I’m using GP Child theme and by switching to GP, the problem remains unsolved.

    But I’ve been using GP for over 2 years and it has performed very well. Right now I couldn’t think of anything I did on the website that could lead to this result…

    I know when Leo tested on GTMetrix, it loads ok because cache was served by then. But when you are logged in (cache will not serve), it’ll take about 10-15s to load the page, and the TTFB alone is 90 percent of the total load time.

    The only thing I did about posts on my site is that I installed a plugin that displays related posts on the single post page, but I deleted that plugin after a short time as it slows down the single post page.

    I’m using Content Views plugin as well. But I can’t see any possible conflict from that either.

    Thanks
    Leon

    #599213
    Tom
    Lead Developer
    Lead Developer

    Maybe you can turn the caching off so the speed tests can get a realistic load time?

    It’s very tough to debug without those tests, as there needs to be something specific on the site causing it. If it was GP itself, our own sites would be running slowly as well.

    If you can’t turn the caching off on your site because of traffic, you’ll need to set up a staging server so we can do our tests there.

    #599255
    Leon

    I totally believe it won’t be GP alone that causes this. I use GP on other sites as well and this site is the only one that has this problem.

    I believe there could be some plugins or some specific scripts that only load on that page that may conflict with GP and not the default theme.

    All caching plugins have been turned off. Autoptimize and WP super cache.

    Thank you for your help!
    Leon

    #599599
    Tom
    Lead Developer
    Lead Developer

    Have you ruled out a hosting issue? Pingdom says it took 9 seconds of waiting until the resources on your page could even begin downloading. That tells me there’s something strange going on with your server.

    Who are you hosted with?

    #599643
    Leon

    Hi Tom,

    I’m using Linode VPS running LNMP. It’s still too technical for me to rule out issues from the server side. However, there are 4-5 wordpress sites hosted on the server, all with GP theme. This page in particular has this problem. Do you think it’s possible that the cause is from the server side?

    Thanks
    Leon

    #600426
    Tom
    Lead Developer
    Lead Developer

    It could be. Have you ruled out some sort of plugin conflict yet?

    #600761
    Leon

    Hi Tom,

    I disabled the blog module from the GPP and now it works fine. Looks like the default view looks ok. So I’ll keep it like this for now.

    Thank you for your help.

    Leon

    #600908
    Tom
    Lead Developer
    Lead Developer

    That’s strange. We have had a couple issues with the image resizer on some servers. That could have been the issue here.

    #600913
    Leon

    Yes Tom. The image resizer wouldn’t work on my site. I set it to 200*200px but it didn’t work. It actually worked at the beginning, but I forgot since which update it stopped working.

Viewing 15 posts - 1 through 15 (of 19 total)
  • You must be logged in to reply to this topic.