[Support request] Blank Editor and SEO Field WP 5.0

Home Forums Support [Support request] Blank Editor and SEO Field WP 5.0

Home Forums Support Blank Editor and SEO Field WP 5.0

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #753431


    After Updating on WP 5.0 the editor is blank and also the seo yoast field…

    I disabled all plugins still same issue (except for the yoast part of course) and with the WP standard theme everything works. The frontend seems fine… i get a lot of js errors and 404 errors in the Chrome console…

    can you take a look at this?

    I tried different browsers (all up dot date) and cleared cash and cookies I’m also up to date with FP 2.2.1 and GP Preiu, 1.7.5


    Try saving your permalinks again. Go to Settings > Permalinks and click Save. No need to change anything unless you’re not using fancy permalinks.

    I had a similar issue yesterday in a site that I manage. I don’t think it was GP caused. In my case the Gutenberg editor failed to load fully because it couldn’t send requests to /wp-json/, which is a virtual page reachable only when fancy permalinks are set.

    If you load the post editor and it all looks blank but you’re browser’s Page Inspector / dev tool shows the HTML structure is present sans content within the HTML structure then you’re problem is probably something similar i.e. the editor can’t load the content because the endpoints are not reachable.

    Customer Support

    Hi there,

    have you tried the above?
    Or install the Classic Editor plugin and make sure it us up to date.


    Let us know. Thanks for the info vr51 🙂


    jep tried the permalink thing before… usually its one of the first things i try… but still same problem… also installed the classic editor… still blank and still a ton of 404 errors und js errors in the console

    oh and just to be clear not everything is blank… only the editor and seo yoast… see here http://prntscr.com/lud3op

    and here a screenshot of the console http://prntscr.com/lud420


    I wonder whether those files are in fact missing. A couple of things to try in order:

    0) check you’re using an up to date version of PHP
    1) Dashboard > Updates > Reinstall WordPress then test again
    2) Reinstall GeneratePress then test again
    3) Confirm that no custom code in your child theme or in GP Elements / Hooks are loading out of date scripts
    4) Disable security plugins then test again
    5) Disable any CDNs that are in use then test again

    If after trying item 1 the problem still exists you might look at the server to confirm the files are present on the server.

    Usually, when it’s only the editor part or Yoast meta boxes that no longer display, and when this coincides with Javascript errors, the fault can often be tracked back to a plugin conflict, which you have already discounted.

    Much of the above you have probably already tried, but if not, they are where I would begin.



    In my case I had a ‘defer parsing of js’ script in my functions.php file in my child theme.

    Once I removed that everything is working again.




    hmm i downgraded to wordpress 4.9… the editor works again… but the first mask of seo yoast is still blank… so this has to be a js issue… i already found some fixes on github but the interesting stuff is that all the errors (404 and js errors) in the console are still showing up… thats really strange

    Customer Support
Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.