[Resolved] Background Image Is Not Showing On Front Page

Home Forums Support Background Image Is Not Showing On Front Page

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #942352
    Andre

    Hi! I am having an issue with my front page. I had this issue before resetting WordPress itself, and now I’m building my site again, I’m experiencing the same issue. I cannot see where my front page image has gone? I uploaded the image and inserted it in the body of the background images tab and it’s not showing.

    I tried to use Inspect to try and trouble shoot the issue to no avail.

    I have a hero elements with a background image the shows fine but the background images tab in customizer seem to be giving me issues.

    Can someone please help to give some light?

    #942356
    Leo
    Staff
    Customer Support

    Hi there,

    The body background image is indeed showing:
    https://www.screencast.com/t/RnjA1TVrih

    The other parts are all blocked by the elements above it.

    You can test by seeing the navigation background to transparent then you should see this:
    https://www.screencast.com/t/MTXMHIks

    Let me know if I’m missing something πŸ™‚

    #942375
    Andre

    Thank you so much Leo. I have managed to locate and move the image, but how did you get the page and image to scroll into view – It’s stuck at the bottom for me?

    https://imgur.com/p75bJr0

    This is all I can manage?

    #942378
    Leo
    Staff
    Customer Support

    Didn’t do anything special. Think it’s all because I’m using a bigger screen πŸ™‚

    #942389
    Andre

    Thank you. I’m having a hard time figuring out why the rest of the image isn’t pushing in view of my window – it’s just disappearing/cutting out at the bottom of my screen like I showed you in the last picture. I don’t even see the css in the inspector! Can you help please?

    #942395
    Leo
    Staff
    Customer Support

    Your screenshot looks normal as well.

    I think you are misunderstanding what a background image is supposed to do – It’s an image at the back of the content regardless how much content there is in front of it (ie it doesn’t push the footer down).

    Try adding more content to that page then you should see what I mean πŸ™‚

    #942396
    Andre

    “It’s an image at the back of the content regardless how much content there is in front of it (ie it doesn’t push the footer down).”

    Lol. I feel so stupid right now. Ofcourse! Problem solved.

    Thank you!

    #942404
    Leo
    Staff
    Customer Support
Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.