[Resolved] backend editing keeps front end styles and blocks don't work as expected

Home Forums Support backend editing keeps front end styles and blocks don't work as expected

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1264044
    Carol Jones

    I have two issues with this site. I don’t think they are related, but I hope whatever fixes them is only one simple problem.

    I have been using WP 5.4.1. I have 7 WP websites, 6 are using GP and , four are using GP and GP Premium with WP5.4.1. I have been using WordPress mostly successfully for about 8 years.

    Scenario: When I go to edit a page or post, I always have gotten a screen/work area that is white and I am able to create new blocks. I can change the types of blocks and all is eventually well. When I set up this one a year ago, I used “Classic” blocks that I could work inside of using the classic editor with styling and other features in the editing tools that I was used to.

    Problem 1: The background of the edit page screen is now colored the same as if I was using the preview feature, the H2 tags are styled like the real page and all the fonts are the same as the front end are. It is as if I’m working on the front end in some way when I’m not, and I don’t want to be.

    Problem 2: The classic editing tools within the classic blocks disappear when I mouse over them so they are useless.

    It seems like something is allowing me to use front end editing similar to a builder program which I do not have or use and don’t want to use. This is the only site that has this problem. Even a brand new site that I started building after this one behaves the way I expect in the backend and not like this one.

    When I set this up at the very beginning about 3 years ago probably, I started using a child theme I downloaded from one of the GP pages, called “Exhibit” and since it is the only GP/WP site where I use that theme, I wonder if that is causing it? Doesn’t make sense to me.

    If I change to just plain GP I will use styles and colors and more hours of fiddling around. I can go back to using the classic editor, but it bugs me that I don’t know what’s causing this weird behavior.

    I hope you can help

    Thanks in advance!!!

    Carol

    #1265138
    Tom
    Lead Developer
    Lead Developer

    Hi Carol,

    You can tell GeneratePress not to style the editor by adding this PHP snippet:

    add_filter( 'generate_show_block_editor_styles', '__return_false' );

    As for the second problem, that sounds like some sort of plugin conflict. Have you tried deactivating all of your other plugins?

    #1265273
    Carol Jones

    Well, that took care of having the font styles show up, and now I know the problems aren’t related, at least not related to what this snippet does. Unfortunately the second issue is the biggest problem. I have only 8 plugins activated (9 with the snippets one I just activated). I need GP Premium, and I have activated and unactivated any that seem to be related to the editor like tinyMCE and Classic Editor. I have to have tinyMCE in order to keep the classic paragraph blocks I set up in the past; without it all the content I’ve entered in the past has to turn into html or be removed. I have to have the Classic Editor plugin now, even though I don’t want it, for the main user to be able to edit new and old posts at all. The only other plugins I have activated are WPForms, NextGEN gallery and NextGEN Plus which I use on all my other WP/GP sites without eve having issues. I’ve switched browsers, cleaned all the caches I know to clear. I deactivated NextGEN pro and activated NextGENplus but it didn’t make any difference, and the whole website depends on those plugins and without them nothing would even be there so there wouldn’t be any backend editing…nor a website. Again, this is the only website using the exact same plugins that is giving me a problem.

    #1265565
    Tom
    Lead Developer
    Lead Developer

    Can you show me a screenshot or a video of the issue so I can try to reproduce on my end? It sounds like a plugin conflict, but I can’t be sure until I actually test it with only GP.

    Let me know 🙂

    #1265681
    Carol Jones

    Yes. I made one but it is too big. I will make another simpler one. Coming right up…

    #1265704
    Carol Jones

    Here is a screenshot video. Without any talking. Be sure to read the text first so you know what is being demonstrated. I hope it works

    #1266434
    Tom
    Lead Developer
    Lead Developer

    Thanks for the video!

    I just played around with it trying to break it but didn’t notice any issues: https://www.screencast.com/t/CQ5cu6IsU

    What browser are you using? Maybe there’s a browser extension getting in the way? Maybe try in incognito mode?

    #1266952
    Carol Jones

    Thank you for your suggestions which made me more exasperated because all my other WP/GP websites look just like your little screencast. I threw up my hands and decided to give up. But as you can guess it was still eating away at me. All the other of my sites are all fine and behave acceptably. I know/knew it was not browser related because I got the same issue in Chrome or Safari.

    So I opened up all my other websites to see what plugins I had, nothing exciting there except there were no settings checked from the right side (under the three vertical dots) and I had been checking and unchecking them on this errant site. So I unchecked all three of them on this site and voila, improvement! Almost fine! So then I went back and activated other plugins like tinyMCE Advanced that I had deactivated and now…tah-dah! Perfect behavior. Took the whole day.

    I really do not know what the culprit was, just a bad combination of settings choices. I think it is NOT related to styled fonts and colors from the frontend showing up on the backend editing pages because that is also happening on some of my other sites, not all.

    I can live with that, but it would be interesting to know why it is like that on some and not all. I thank you for the php snippet which I can use.

    Over and out on this for now. Thanks again for your efforts.

    #1267726
    Tom
    Lead Developer
    Lead Developer

    Awesome, really glad you were able to find the culprit! 🙂

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.