[Resolved] Aw Snap when I try to change logo

Home Forums Support Aw Snap when I try to change logo

This topic contains 11 replies, has 3 voices, and was last updated by  Tom 4 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #645015

    Anne Eglash

    Hi All:
    I’m new to GP. Installed Wordsmith theme into a local dev site.
    When I attempt to change the logo, I see the media library, but then Aw, Snap.
    I am able to load the logo image into the “Retina Logo” section.

    The only non-GP plugin is LearnDash. This crash occurs even when LD is disabled.
    Any suggestions?
    Thanks.

    GP Premium 1.6.2
    #645105

    Leo Customer Support

    Hi there,

    It could this:
    https://docs.generatepress.com/article/increasing-php-memory-limit/

    Give it a shot and let us know if this helps 🙂

    #645140

    Anne Eglash

    I added the memory limit and restarted the server.
    I’m able to change the site logo.
    Note that when I try to change the logo, the media library loads and the crash happens before I can even select an image. I.e. the media lib screen is visible, but image selection does not work and then the crash happens about 10 seconds later.
    This does not happen when I load the Media Lib from the Retina and Site Icon sections of the Customizer.
    Thx.

    #645167

    Leo Customer Support

    Hmm this sounds like a problem from the WordPress end.

    Might be worth asking your host to check if everything is all good.

    We haven’t had this reported before so I highly doubt it’s due to GP.

    Let me know if this helps 🙂

    #645212

    Anne Eglash

    I’m running on localhost, using the Bitnami WP Stack.

    #645241

    Leo Customer Support

    Might be good to check with Bitnami WP Stack then.

    You can also test by switching to a twenty-series default WordPress theme. If the problem exists still, then it’s definitely not GP.

    #645273

    Anne Eglash

    Good suggestion. Here’s what happens:
    I switched to Twenty Seventeen, then appearance/logo and change the logo. No problems.
    Back to GeneratePress, appearance/logo, I still see the Wordsmith logo. Try to change the logo, Aw, Snap.
    Change back to Twenty Seventeen, it has our logo.

    Note also the Twenty Seventeen sees the Site Icon that I set using GP.

    #645365

    Tom Lead Developer

    Hi there,

    Can you try using Incognito mode? That will rule out an issue with your browser extensions.

    Let me know 🙂

    #645384

    Anne Eglash

    That worked!
    Tested it twice.
    Interesting that it is only the logo setting that causes the conflict.
    Thanks.

    #645424

    Tom Lead Developer

    No problem! One of your extensions might be taking up a lot of browser memory. Combine that with WordPress opening the media module (with cropping maybe?), and it sounds like it was crashing your browser.

    #646224

    Anne Eglash

    Quick followup – the plugin conflict is with Dashlane.
    I logged into the backend w/FireFox.
    When I attempted to change the logo, FF reported that Dashlane was slowing down the page and offered to disable it for that page. This worked.
    I then disable Dashlane in Chrome for the site (again running local) and the crashing problem is gone.
    So FFox handled the problem where Chrome crashed.
    Thx.

    #646417

    Tom Lead Developer

    Good to know – thanks for reporting back! 🙂

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.