[Support request] Author info in structure data

Home Forums Support Author info in structure data

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #951682
    John

    Hello

    I’m using team member via after_content hook instead of single author box. That’s why I disabled author meta from blog settings. Author meta is successfully disappeared from my site.

    But In structured data testing tool, I notice still remain author meta info such name, ID, Gravatar in article section.

    I read google quality guidelines, They suggested “Don’t mark up content that is not visible to readers of the page”

    Screenshot – https://prnt.sc/obyljp

    Source Link – https://developers.google.com/search/docs/guides/sd-policies#quality-guidelines

    I’m afraid about google quality guideline violation. Is That any issue?

    I need your suggestion.

    Thanks

    #951944
    David
    Staff
    Customer Support

    Hi there,

    the structured data is being generated by Yoast – this article explains more:

    https://yoast.com/yoast-seo-11-0/

    They also provide an API for changing / removing their structured data:

    https://developer.yoast.com/schema-documentation/api/#disable-schema

    #952144
    John

    I disabled Yoast schema and enable article schema from GP.

    But FInd 2 error in structured data testing tool.

    #952204
    John

    I read google quality guideline again.

    Maybe Google indicate actual content instead of author.

    And, The Author(Which is display on structured data testing tool) is still remaining in team member as well.

    Am I wrong?

    And Is there any way to add schema markup for team member?

    #952207
    David
    Staff
    Customer Support

    Reading the guidelines i cannot see any issue with the author data being present without it being on the page – its not being deceptive.

    And yes as you have a visual guide of the author in the team member then it certainly shouldn’t be an issue.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.