[Resolved] Ajax error, but not problem of Generatepress!

Home Forums Support Ajax error, but not problem of Generatepress!

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #965256
    retroreiz

    Hi guys,

    you have always helped me quickly and really well, so I turn to you, although I suspect that it can not be due to GeneratePress.

    I bought the plugin package from xforWoocomerce about 5 days ago and I’m currently testing it.

    Currently I have the problem on the product archive page. I have products that can only once be added to the shopping cart.

    Normally if I do not use the plugin of xforWoocommerce, then the message appears that I already have the product in the shopping cart and can not add again. That’s right. But if I activate the plugin, then I get an Ajax error, as soon as I want to add the product again to the shopping cart.

    Now I have tried everything possible. All plugins disabled, standard theme used, but the plugin of which still causes an Ajax error.

    Since I’m not technically talented and php code can not really read, I wanted to ask you briefly.

    In the log is the following when the Ajax Error comes:

    CRITICAL Uncaught Error: Call to undefined method WC_AJAX::json_headers() in /usr/www/demo/wp-content/plugins/xforwoocommerce/x-pack/product-loops/includes/pl-frontend.php:944
    Stack trace:
    #0 /usr/www/demo/wp-includes/class-wp-hook.php(286): XforWC_Shop_Design_Frontend->add_to_cart('')
    #1 /usr/www/demo/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters('', Array)
    #2 /usr/www/demo/wp-includes/plugin.php(465): WP_Hook->do_action(Array)
    #3 /usr/www/demo/wp-admin/admin-ajax.php(188): do_action('wp_ajax_nopriv_...')
    #4 {main}
      thrown in /usr/www/demo/wp-content/plugins/xforwoocommerce/x-pack/product-loops/includes/pl-frontend.php in Zeile 944

    In the php file in the line 944 is the following:

    			else {
    
    					WC_AJAX::json_headers();
    
    					$data = array(
    						'error' => true,
    						'product_url' => apply_filters( 'woocommerce_cart_redirect_after_error', get_permalink( $product_id ), $product_id )
    					);
    
    					$data = json_encode( $data );
    			}

    The support is of the opinion that I am doing something wrong, or I use a theme / plugin that children have programmed.

    Since they represent me now as stupid, I wanted to know if you can say something more specific to the error message?

    I would really appreciate it if you could help me somehow.

    Best regards, Andreas.

    #965380
    Leo
    Staff
    Customer Support

    Hi there,

    Unfortunately we cannot provide support for other plugins.

    Just to confirm, you get the same error when using a WP default twenty series theme?

    If so it’s absolutely a plugin problem and you should take it to the developer.

    If they refuse to solve the issue then might be good to ask for a refund.

    Let me know if this helps 🙂

    #965651
    retroreiz

    Hi Leo,

    i understand that, of course.

    I’d just like to know if maybe the error log tells you something. Does that sound more like wrong programming?

    And yes, even with a standard wordpress theme comes the same problem. The plugin manufacturers just do not want to see it and say that I have made a mistake. A very bad support 🙁

    When I compare how fast and helpful answers you deliver and even run a public forum. Very exemplary 🙂

    Best regards, Andreas.

    #966114
    Leo
    Staff
    Customer Support

    It’s definitely a plugin issue if it happens with a default theme as well.

    That’s too bad. I would recommend asking for a refund as soon as you can and possibly report that to WordPress.

    #967722
    retroreiz

    Good day,

    after much back and forth, xforwoocommerce has finally admitted that it is a bug 🙂 They want to fix it soon.

    Thank you for your work together.
    Greetings Andreas

    #967957
    Leo
    Staff
    Customer Support
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.