[Resolved] Admin Bar disappears after update to 2.3

Home Forums Support Admin Bar disappears after update to 2.3

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #935545
    Jagdish

    Hi,

    After update to 2.3 my admin bar is not visible.

    Can you help into this please?

    #935958
    David
    Staff
    Customer Support

    Hi there,

    thats peculiar – as i can’t see why the CSS size would increase, and not sure whether the above link is the cause for this.

    In Customizer > General – there is an option to Combine CSS – what happens if you activate that?

    #935990
    Jagdish

    I was not sure about the reason given in the link, that is why I edited the post.

    Combine CSS doesn’t changed anything.

    One clarification: Admin bar is not visible on post pages only. I am Sorry for not mentioning this earlier.

    #936000
    David
    Staff
    Customer Support

    Are there any errors in your Developer Tools ( Right Click > Inspect ) > Console when viewing the posts?

    #936405
    Jagdish

    Found this one error only. Everything else is fine.

    [Error] Failed to load resource: the server responded with a status of 404 () (ww.js.map, line 0)

    #936426
    Leo
    Staff
    Customer Support

    Does the same thing happens if you are using a default twenty series theme from WordPress?

    #936524
    Jagdish

    Not visible in twenty Nineteen also with AMP plugin.

    But in Generatepress if AMP plugin is active and I deactivate GP premium or Yoast SEO (Either of them) then Admin Bar is visible.

    If I deactivate AMP plugin only then Admin bar is visible in both themes.

    Sorry if it is little confusing.

    #936784
    David
    Staff
    Customer Support

    Not sure what would have changed with the latest version that would effect this. Do you have all of the GP Premium Modules activated in Appearance > GeneratePress? Could you try disabling them one by one to see if one in particular is causing a problem ?

    #937054
    Jagdish

    I checked all the modules. Admin Bar is not visible when Elements or Secondary Nav (either of one) is active.

    #937066
    Jagdish

    Finally I got the culprit. There is a hook on every post page at after main content. If I remove that hook, admin bar is visible. Hook contains short code from WP Show Posts and I am using it to show related posts.

    #937154
    Tom
    Lead Developer
    Lead Developer

    Can you share the content of the Hook with us?

    Let me know 🙂

    #937162
    Jagdish

    Shortcode from WP Show Posts

    Screenshot-2019-06-21-at-10-21-31-PM
    Screenshot-2019-06-21-at-10-21-53-PM

    #937198
    Leo
    Staff
    Customer Support

    Really don’t see how that can be the issue at all.

    Just to confirm, this issue doesn’t exist when using a twenty series theme without any activated plugins?

    And then when using Generatepress, the problem exists when you have no other plugins activated except GP Premium?

    #937324
    Jagdish

    Yes, let me say it like this

    All plugins deactivated – Admin bar visible on both themes.

    AMP Activated – Admin bar visible on GP but not on Twenty Nineteen.

    All other Plugins with AMP activated one by one but Admin bar is still visible on GP.

    At last when I activate GP Premium then Admin bar is not visible.

    Now if I deactivate any one module like elements or secondary nav then again admin bar is visible.

    #937456
    Tom
    Lead Developer
    Lead Developer

    Do you have any recent errors in your error_log file on your server?

    The randomness of this makes me think it might be a PHP memory issue.

Viewing 15 posts - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.