[Resolved] 500 Error with no log entry for Site Library template install (Agency)

Home Forums Support 500 Error with no log entry for Site Library template install (Agency)

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1318238
    John

    Hello. I have been trying to install the Agency theme through the Site Library.
    I have the latest GP theme and GP Premium installed
    This is a fresh install on a new EC2 instance with correct permissions applied

    I am able to select the theme (agency), then progress to step 1 of 3. Step 1 works fine, but step 2 fails at ‘importing content’

    the ajax call responses from step 2 are:
    instal plugins — plugins activated
    download content — blank (but no error)
    import content — There has been a critical error on your website.

    The apache error_log shows nothing and there is no debug.log in my wp-content regardless of what I have in wp-config.php
    I have set wp-content to have 0777 perms.

    The only thing that I haven’t done is set up FTP – I’ve been importing plugins and the theme direct, with FS_DIRECT defined in wp-config. Could that be related?

    I’d really like to utilize the theme templates. Is there a way to do it manually? What’s odd is NOTHING is in the error log. I do have output there, but nothing from this install process.

    #1318285
    John

    I think perhaps the downloaded file failed, and the import threw a 500 bc there wasn’t a file to import. Should I be seeing a downloaded file in ‘wp-content/upgrade’? I don’t…

    I also tried installing a different template and got the same error.

    #1318288
    John

    Wait, I found the xml files in my uploads/2020/06/ folder. So, it appears it did download the template data. The import is failing.

    #1318398
    John

    Doh! When I rebooted the instance as a t2.small (originally a t2.micro) it worked. Most likely a PHP memory error despite setting the generatepress recommended settings (for httpd.conf)

    #1318503
    Tom
    Lead Developer
    Lead Developer

    Glad you got it sorted! Thanks for sharing what it was 🙂

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.