[Resolved] 500 error while importing Merch demo content

Home Forums Support 500 error while importing Merch demo content

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1055510
    Steve

    Hi GP. First time user. Am setting up a test site.
    Error occurs during import of Demo Content immediately after last plugin installed WP Show Posts.
    Have done “Removing an Imported Site” and tried again with same error.
    Then removed all other plugins and themes and tried again with same error.
    Have also followed “Error Codes While Importing – Server Error 500” with same error.
    However on cpanel with my host can only increase post_max_size to 128M not 512M. As a result I have also reduced upload_max_filesize to 128M.
    Spoke with my host about why I cannot increase post_max_size to 512M.
    Their response is they don’t believe that is the problem. They are seeing the below error;

    I am seeing errors generated indicating an issue with another plugin [07-Nov-2019 04:45:51 UTC] PHP Fatal error: Uncaught Error: Class ‘XMLReader’ not found in /home/complete/public_html/wp-content/plugins/gp-premium/sites/libs/wxr-importer/WXRImporter.php:124

    #1055513
    Steve

    I thought I would try to import another Site Library Arctic but had the same error.
    I then ticked the skip demo data and it finished without error.
    This is the wp debug log;

    #0 /home/complete/public_html/wp-content/plugins/gp-premium/sites/libs/wxr-importer/WXRImporter.php(332): GeneratePress\WPContentImporter2\WXRImporter->get_reader(‘/home/complete/…’)
    #1 /home/complete/public_html/wp-content/plugins/gp-premium/sites/classes/class-site-helper.php(185): GeneratePress\WPContentImporter2\WXRImporter->import(‘/home/complete/…’)
    #2 /home/complete/public_html/wp-content/plugins/gp-premium/sites/classes/class-site.php(811): GeneratePress_Sites_Helper::import_xml(‘/home/complete/…’, ‘arctic’)
    #3 /home/complete/public_html/wp-includes/class-wp-hook.php(284): GeneratePress_Site->import_content()
    #4 /home/complete/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(”, Array)
    #5 /home/complete/public_html/wp-includes/plugin.php(465): WP_Hook->do_action(Array)
    #6 /home/complete/public_html/wp-admin/admin-aj in /home/complete/public_html/wp-content/plugins/gp-premium/sites/libs/wxr-importer/WXRImporter.php on line 124

    #1055515
    Steve

    Sorry. I have now read this support document that has the answer;

    https://generatepress.com/forums/topic/500-internal-server-error-2/

    Can you contact your host and ask them to install php-xml (XML Reader class)?

    #1055613
    David
    Staff
    Customer Support

    Hi there,

    yes that error is related to the host having the XML module disabled in their PHP config.
    Without it the importer module will not work

    Not related at all but I would also challenge them on your memory limit, although 128mb may be ok for standard sites it can get eaten up quickly, especially if you use a pagebuilder or woocommerce – i recommend a minimum of 256mb but personally all my installs have a min of 768mb.

    #1055633
    Steve

    Thankyou for the reply. This test involves reviewing my host as well as my current premium theme.

    #1055761
    David
    Staff
    Customer Support

    You’re welcome. Hope you’re successful in your testing.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.