Reply To: GP Portfolio Child Theme + CPT

Home Forums Support GP Portfolio Child Theme + CPT Reply To: GP Portfolio Child Theme + CPT

#164698
Roberto Enrique

If you use this child theme in a single standard WordPress installation it works just as you expect it should, but there are some small issues in multisite, regarding “portfolio” archive page that I’m trying to solve right now, may be with a little help from you 😉

First, let me explain my configuration.

* I’m running a multisite network on a shared host and everything is running smoothly, the main network site is http://www.artomultiplo.net
* Some sites are using WPMUDEV’s Domain Mapping plugin (so websites like mastromiliano.artomultiplo.net appears as mastromiliano.it)
* In that shared host I have some other websites that are not connected to the main network (they’re just add-on domains pointing to sub-folders, some of them are just sub-domains always pointing to a sub-folder)
* There is an “isolated” installation of wordpress (a stand-alone vanilla installation of wordpress, not a sub-site of the multisite) that I use just to show a child theme I put together to allow a simple integration of wp-theming’s “Portfolio Post Type Plugin” (http://wptheming.com/2011/08/portfolio-post-type-plugin/). The url of that site is portfolio.artomultiplo.net and it works as expected BUT…

I realized that, while the plugin is actually working for the sites on the main multisite, as you can see here: http://mastromiliano.it/portfolio/candelabro-144/ if you go to the “archive” of that website, which should just work when you add the “portfolio” slug at the end of the url (wether you use this path mastromiliano.artomultiplo.net/portfolio or mastromiliano.it/portfolio) you land in portfolio.artomultiplo.net but the url is right :-S

If I “delete” the “isolated” website that contains the portfolio child theme (portfolio.artomultiplo.net) then in mastromiliano.net/portfolio you can see what is intended to, the mastromiliano.it portfolio archive page, but it does not work (the archive page with the portfolio slug) in other sites of the network. (let’s say http://detech.it/portfolio/this-is-a-portfolio-item/ while http://detech.it/portfolio/ does not)

To say it short: My problem is with Archives for portfolio post type, they behave very weirdly when they work. Is there a way to just display the portfolio archive page of the sub-site and not the portfolio.artomultiplo.net homepage?

Thanks in advance, and have an awesome weekend you all!